ツイキャス配信やOBS Studioで出た不具合

私がツイキャスで配信したりOBS Studioを使って配信した際に出た障害みたいなもの。

ネットで対応策調べて解決したものは解決策を記述。

 

ツイキャス配信時、視聴者側ですぐにBufferが0になってブツブツ切れる

ツイキャスで初期に発生していた不具合ですね。まだOBSを使う前のことです。

初めはまだ「ツール配信」もできず、音声だけのラジオ配信でたいして通信量も多くないだろうしなんでこんなことが起こるのか不思議でした。

対応策:ツイキャスの配信画面の下の方にある「高度な設定を開く..」をクリックして開いた画面の「回線速度 」の項目を「ブロードバンド」から「モバイル」に変える。

 

これは推測になりますが、おそらく設定を変更したところにあるように
目安: モバイル <500kbps, ブロードバンド >1Mbps
というのが、ラジオ配信だからデータ量が少ないとかでなくそのまま効いてくるのだと思います。

よく見てみると「ミュート」ボタンの横の「ラジオ配信」ボタンで、「Webカメラでの配信」と固定画像で音声だけの「ラジオ配信」をワンタッチで即座に切り替えられるのですが、ここが引っかかるところで…

つまりこうも一瞬で切り替えられるということは「Webカメラでの配信」で使っている帯域の設定はそのまま「ラジオ配信」でも引き継がれていて、「回線速度」の設定を「ブロードバンド」にしていた場合音声だけの配信でも1Mbpsに匹敵するデータ量が流れることを想定されているのではないか…と。

で、ツイキャス側では1Mbpsでデータが来るものだと思っているにも関わらず、送信元からは(ダメダメ回線の為)1Mbps未満しかデータが送られてこないので、貯めてあったbufferはすぐ空になり新たなデータがbufferに貯まるまでは視聴できない…それが数十秒ごとに繰り返される…

という状況だったのではないかな?^^;

 

現在は「高画質配信」or「ツール配信」ができるようになり、流れるデータ量はOBS Studio側の方で設定出来るため(映像200kbps+音声96kbpsをアフリカTVとツイキャス同時で配信296×2=592kbps)、上記のような通信がブチブチ切れる…なんて症状はでなくなりました。

めでたしめでたし。

 

 

音声が山彦のようになる(遅延した音声がのる)

テスト配信時に気づいたのでよかったですが、ネットで対応策検索できない人は躓きそう…

対応策:OBS Studioの「デスクトップ音声」の「設定(歯車)」から「プロパティ」を開き、「デバイスのタイムスタンプを使用」のチェックを外す。

 

ネットで参考にさせてもらったページはこちら。↓

一部環境下で発生するOBS Studio「デスクトップ音声」がズレる(遅延/遅れる)現象
Clara Style OBS Studioの分かりづらい設定紹介)
http://ch.nicovideo.jp/kenta0644/blomaga/ar646845

 

 

OBS Studio 起動する度に音量が下がる

これは配信始めてから気づいて毎回右下のタスクトレイから「音量ミキサー」を呼び出してボリュームあげなおしてました。^^;

ネットで調べたら簡単に対策できることがわかって嬉しさの反面「今までの苦労は…」と思いました。

対応策:windows画面右下「タスクトレイ」 から 「音量調整(スピーカー) 」を右クリック、「 サウンド」を開く。「通信」のタブを選択し、「他のすべてのサウンドの音声を80%下げる」とかになってるのを「何もしない」にする。

本来はSkypeとかで通話する時に自動的にデスクトップとかで流してるBGMの音量を自動的に下げてくれる機能なのですが、何故かOBS Studioの起動をトリガーに発生してしまうようで…なんでだろ?

 

参考にさせてもらったサイトはこちら↓

◆OBS Studio起動後にシステム音量(デスクトップ音声)が下がる(小さくなる)現象
(Clara Style OBS Studio 自分用ニコ生設定メモ(Win))
http://ch.nicovideo.jp/kenta0644/blomaga/ar1030770

 

 

回線断後のツイキャスでの配信復活方法

アフリカTVではOBS Studioでそのまま配信状態であれば再接続してそのまま視聴してるブラウザ更新すれば見れるのに、ツイキャスでは再接続もしてくれないしOBSで「配信終了」からの復帰も微妙で困っていました。

結局明確な対応策は見つかっておらず、安定した光回線が導入されるまではとりあえず付け焼刃的な対応になってしまいますが…

 

とりあえずの対応策:OBS Studioで「配信終了」→「配信停止処理中…」の表示になる→「配信開始」の表示になるまでじっと待つ→「配信開始」をクリック…

 

 

尚、TwitCastingの公式ページにこんな記述がありました。

配信ツールの自動再接続機能について

配信が一度終了した後、意図せず配信が再開されるなどの事態を防ぐため、再度配信をするには一定以上の間隔をおく必要があります。
配信終了後、再度配信をしようとして失敗してしまった場合は、配信ツールの接続をいったん切断し、数十秒程度の時間をおいてから再び試してみてください。
また、自動再接続の機能をオフにしてご利用ください。 自動再接続機能の詳しい設定方法については、各配信ツールのヘルプ等をご覧ください。

PCで外部ツール配信をするには
http://twitcasting.tv/indexannounce.php?title=ANNOUNCE_JA_HELP_GAME_TOOL

 

こういうことも書いてあったのでOBS Studioの「設定」の「詳細設定」の中にある「自動的に再接続」の「有効にする」のチェックは外しておいた方が無難かもしれません。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です